Formulario para Consultar el Precio y Foto de nuestros Productos


En este tutorial te enseñaré a crear una lista de precios para tus productos, incluyendo foto.

Descargar


I. Contenido Inicial:


Hoja bd: Contiene la tabla de artículos.
La información y fotos de los artículos estarán almacenados en una tabla de Excel, se reservará la última columna para insertar las fotos. A mayor tamaño de imagen, mayor será su tamaño en el visor.



Hoja excelsoluciones: Nuestra hoja de trabajo

Haciendo uso de las funciones Buscarv, Coincidir y Rangos Dinámicos, nuestra aplicación podrá mostrarnos el nombre, precio y foto del producto buscado.


II. Instrucciones:


Paso 1: Crear la lista desplegable de Artículos

Accede a la hoja excelsoluciones y posiciona el cursor en la celda D12, accede al menú [Datos] y luego elije la opción [Validación de Datos]. A continuación elige la opción [Lista] y con ayuda del mouse, selecciona todos los artículos que deseas incluir como Origen de Datos.

Nota: La lista de artículos se encuentra en la hoja bd.


Resultado:



Paso 2: Enlazar la lista de artículos a la celda auxiliar

La idea es obtener el indice del artículo elegido en lista, para ello utilizaremos la función Coincidir.  Posiciona el cursor en la celda U12 y agrega la siguiente formula:

=COINCIDIR(D12,BD!$C$2:$C$6,0)

Paso 3: Crear un Rango Dinámico

Accede al [Administrador de Nombres] y agrega lo siguiente:


El nombre de rango dinámico es "rango_fotos" y la formula correspondiente:

=DESREF(BD!$E$2, COINCIDIR(excelsoluciones!$U$12,BD!$A$2:$A$6,0)-1,0)

Donde:

  • BD es la hoja donde reside la tabla artículos.
  • E2 es la primera celda de la columna fotos (sin contar el encabezado).
  • excelsoluciones! es la hoja de trabajo.
  • U12 es la celda auxiliar donde se muestra el número de elemento elegido de la lista desplegable.
  • BD!A2:A6 representa la columna [Nro].

Nota: Si la formula nos arroja un valor #N/A, se debe a que no hay artículo elegido en lista.


Paso 4: Asociar Rango Dinámico con Foto


En la hoja [excelsoluciones] he agregado una imagen de una cámara fotográfica (puede ser cualquier otra), esta imagen debe estar enlazada con el rango dinámico que haz creado. A continuación selecciona la imagen y escribe en la barra de fórmulas lo siguiente:

=rango_fotos

Ahora elige un artículo de la lista y verás su imagen correspondiente.


Paso 5: Obtener Precio del Artículo

Utiliza la siguiente fórmula para obtener el precio del artículo en función a su nombre:

=BUSCARV(U12,BD!$A$2:$D$6,4,FALSO)


Donde A2:D6 es el rango de la tabla, U12 el número de elemento en lista y (4) representa el número de columna a extraer; en este caso corresponde [Precio].

Con esto hemos terminado la aplicación, ya puedes utilizarla. Espero te haya gustado, no olvides comentar y compartir.


Puede apoyar esta web con una donación, cualquier cantidad es apreciada. Mediante la donación podrá ayudar a mantener el sitio y encontrar más cosas.

Sígueme en Facebook

Al suscribirte tendrás acceso a tutoriales y demás recursos gratuitos de corte exclusivo.